Resolving the "Could Not Load File or Assembly, Version=4.0.0.0" Error

Overview

Error: Could not load file or assembly, Version=4.0.0.0.

This error indicates that the System.EnterpriseServices file, which is used by Microsoft .NET Framework 4.0, is not registered in theWindowsassembly folder.

Proper functioning of the .Net Framework is required for SmartVault.

Resolving This Error

To resolve this issue, complete the following tasks:

  • Download and install or reinstall Microsoft .NET Framework 4.0.
  • Ensure you have the latest service pack and critical updates installed for the version of Microsoft Windows running on your computer.
  • Disintegrate and then reintegrate your QuickBooks company file with SmartVault.

Download and Install or Re-install Microsoft .NET Framework 4.0

  1. Go to Microsoft .NET Framework Downloads.
  2. Read the download instructions on the page.
  3. Select, download, and install Microsoft .NET Framework 4.0.
  4. Restart your computer.

Install Latest Service Pack and Critical Updates

Run Windows Update and Install the latest service pack and critical updates for the version of Windows that you are running.
To learn about Windows Update, click here.

Reintegrate Your QuickBooks Company File

Reintegrate a QuickBooks Company File

...