Overview
When trying to integrate a QuickBooks company file with SmartVault, you receive the error:
"System.Exception: Adding this company to your account 'Account' would exceed your company limit. Please upgrade your account to allow more companies, and then add the company again."
Cause
You have already used up all your available company file licenses on your account.
Resolving This Error
You will either need to remove* unused company files in your account or purchase additional company file allotments.
- Sign in to the SmartVault Client portal.
- Under My Account, select your account where you want to add the company file.
- Click the "Upgrade My Account" link on the right-hand side under Usage, or Right-click the account name and select Manage Bill
- Increase the number of company licenses you need on the table, then click Save.
To remove unneeded company files from the account, refer to this topic: Remove QuickBooks Company Files